Donnerstag, 16. Februar 2017

Map-Plot and plotting in background

Again it took me some time to figure out that Map-Plot and AutoCAD background plotting don't go well together. With Map 2013 we did use Map Plot for plotting maps as PDFs and we did not have an issue with regards to background-plotting although I do not know whether we just had not enabled background-plotting or the behavoir has changed in Map 2017.

Here are a few observations of Map 2017 and Map-Plots:

- Map Plot batch plotting does not work, Map will crash after the second plot and no PDF will be created
- if a single Map-plot is plotted manually (via context menu) an AutoCAD layout is being created and the map correctly rendered but it wont plot to the device (at least as long as a PDF plotter is being used), one needs to plot the AutoCAD layout manually
- when the AutoCAD layout has been created and the layout is plotted the resulting PDF file is sometimes empty, if the layout is plotted a second time the PDF file will be fine (if background-plotting is enabled)
- when the layout has been created and the layout is plotted error messages might appear:
FDO-Verbindung konnte nicht geöffnet werden. (cannot open FDO connection)
ORA-01005:  kein Kennwort angegeben; Anmeldung verweigert. (null password given; logon denied)
...
WARNUNG: Beim Anwenden von Stilen auf das Element PLT_V_GRID_EXTLINE_TBL sind folgende Probleme aufgetreten:
Objektquelle ist nicht verbunden. (whilst applying styles to element PLT_V_GRID_EXTLINE_TBL the following issue occured: feature source not connected)
...
and the PDF is created correctly (if background-plotting is enabled)

If you use Map-plots and you run into issues check whether background plotting is enabled or not. If you need batch plotting and you get crashes as well - have a look here.

I also noticed that disabling background-plotting seems to be ignored until Map is restarted,.

Map 2017, SP1

Keine Kommentare:

Kommentar veröffentlichen