Samstag, 18. Mai 2013

DWG Export - Linientyp XYZ nicht in Vorlage gefunden


Beim DWG Export erscheint die Meldung, dass bestimmte Linientypen in der Vorlage nicht gefunden wurden, obwohl diese dort vorhanden sind:
 
Befehl: _-MapToACAD Exportmethode [Bearbeitbar/Visuell]: _Editable Dateityp speichern [AutoCAD-2013-DWG/AutoCAD-2013-DXF/AutoCAD-2010-Drawing/AutoCAD-2010-DXF/AutoCAD-2007-Drawing/AutoCAD-2007-DXF/AutoCAD-2004-Drawing/AutoCAD-2004-DXF/AutoCAD-2000-Drawing/AutoCAD-2000-DXF]: _Dwg2013 Dateispeicherort: "C:\Temp\DWG_Export\wt_fm_mlinie.dwg" Die Datei C:\Temp\DWG_Export\wt_fm_mlinie.dwg ist bereits vorhanden. Sie wird überschrieben.
XDaten erstellen [Ja/Nein]: _No Speicherort der Vorlage (DWT): "C:\Temp\DWG_Export\PZ_WFM.dwt"
Linientyp AC_LType_GA_PIPE_2LINES nicht in Vorlage gefunden. Stattdessen wird VonLayer verwendet.
Linientyp AC_LType_WA_PIPE_AXE nicht in Vorlage gefunden. Stattdessen wird VonLayer verwendet.
 
Ursache könnte sein, dass der Linientyp ursprünglich als XML-Datei in den Stil-Editor eingelesen wurde. Dann speichert Map automatisch unter dem Tag <ExtendedData>einen Verweis auf die XML Datei im Layer ab:
 
<ExtendedData1>
<FileName>S:\GIS\TOPOPAR\PZ_MAP2013\WA_CH_DE_Wasser\LTypeDefinitions\AC_LType_GA_PIPE_2LINES.xml</FileName>
</ExtendedData1>
 
Löscht man den Verweis auf den Dateinamen aus der Layerdatei, funktioniert der Export wie erwartet.

Map 2013, SP1.
 

1 Kommentar:

  1. Kann ich bestätigen für Map 2012
    Vielen Dank für den Tipp, endlich sehen unsere Ausser Betrieb Leitungen gleich so aus wie sie sollten.

    AntwortenLöschen